vendredi 10th février 2017

Mailservers Hotmail/Outlook and other Microsoft addresses sending issues

Monitoring - This is still ongoing, we are continuously monitoring this and will keep this page up to date with the latest information.

Investigating - We are currently seeing a large amount of emails being deferred when sending to Hotmail/Outlook and other Microsoft addresses. This includes and domains that have emails hosted with outlook services.

This looks to be caused by a limit on their servers restricting the amount of emails that can be received from our shared mailservers. Our sytem admin team are currently investigating and attempting to contact them for further details, or a possible work around.

On inspection this may not be effecting all emails sent to these addresses, but a large amount are being blocked. This will cause bouncebacks to the sender, so you can see which emails have been blocked.

Our apologies for any inconvenience caused here in the meantime.